QSC CX 404….Don’t try this at home

I had a worrying thought. It might have been yesterday. Having not very many of them (thoughts, that is) I ought to be able to remember one. So that was a bit worrying as well. It was regarding the prime minister. I realised that I didn’t know who it was/is; then I was even more worried by the fact that I didn’t care who it was/is.

He has paid me a hundred quid towards my heating bill, and I thought it would be nice to send him/her a note. Obviously to 10, Downing Street.  But you can’t address it to ‘Somebody, 10, Downing Street. The cat might get it. Anyway, lead onwards and outwards, Macbeth!

Ah….yes! The CX 404. The amp with more things to go wrong in it than a politician. It has a complex switch mode power supply, with a load of things to go wrong in that. It has four separate amps in it to go wrong. It has a bagful of protection circuits to protect it from going wrong, all of which can go wrong. The only way you should take on a job like this is with a bazooka levelled at your head (or somewhere) and Mills grenade taped to both hands. That’s the most useful information I might come up with. Suffice it to say, I recently repaired one of these. This I put down to stupidity of a high order.

The power supplies had blown. These are IGBT (insulated gate bipolar transistors) that do the power switching, and they’re not cheap. There are two chips that generate the switching pulses and provide the drive to the IGBT’s. If the IGBTs are cleaned out it’s pretty likely that so are these two chips. But if there is a fault in any of the power amps, the amp will cycle on\off etc. and the power supplies won’t operate even if they’re ok, because of the dc sense circuits. Or, of course, it could be because the sensing circuits are sensing something that isn’t there at all.

The power transistors you need to take out to check if they are the ones in the schematics. The one I had, had two pairs of completely different ones in it, to the ones in the schematic. The drivers were the same MJE15032 and 15031 I think.

There is another issue with these. The heatsinks clamp down onto the top of the power transistors (there are four separate ones, one for each amp. That’s fine when they’re first built, but I discovered that different manufacturer’s devices can vary a bit in the physical thickness (back to politics) which means that your heat sink might not make such a good contact with the device. Not good news.

I got fair number of useful lessons out of this amp. The main one certainly to be very wary in taking them on.

Being deserving of at least several cups of tea and a pallet load of macaroons, I shall attend to those matters.

 

Comments are closed.