Laney VC30. The ‘VC’ stands for ‘Very Cwiet’.

Well, the light came on. Always a good sign. But the speaker did not speak to us.

A quick look through the rear grill told all. It was dark as the Munsters’ lounge. Or Trump’s thought processes. Not a working heater was to be found.

Inside the amp a toroidal mains transformer is mounted on the chassis, and from that, eight cables connect from the secondary of that transformer to an eight way, dual-in-line connector. The female end of this is flying and the male counterpart is fitted into the chassis. There is an interesting piece of design thinking here. Two of the cables carry the heater voltage/ current. The voltage is 6.3 volts rms. But the heater current through this connector is the total of all the heaters in the amp which is around three amps.

The connector, however, has a rating of one amp, and therefore has to carry a current that is three times its rating. Sooner or later, this is going to burn up, and it did.

The practical method of sorting this problem out is to cut all the cables on the transformer side, and solder long insulated link cables to them. The male part of the connector we prize out of the chassis. You need to make notes of what cables went to which when the connector was fitted. Then all the cables are cut to the connector. This makes it easier to desolder the cables from the pcb. Then your links from the transformer are soldered to the pcb in the order that you (hopefully) noted when you cut the cables.

This has effectively got rid of the burned connector and hard-wired the transformer wiring to the pcb.

I’ve had similar problems (for the same reasons and with similar repairs) on some Fender reissue amps. It’s a time-consuming fix, but at least the fault will not occur again.

Unless you are particularly slick with a soldering iron, this would be best left to your local tech gentleman.

Tea calleth.